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1 Introduction

Mixed-Signal circuit design especially for high-speed applications is very intricate and requires val-
idation of certain figures-of-merits (FOMs). This tutorial provides a detailed guide to analysis and
simulation of mixed-signal circuits like voltage-controlled oscillators (VCOs) used in clocking circuits
for high-speed link applications. A VCO model in Verilog-A is presented and a step-by-step guide
to transient reponse and jitter calculation using Cadence Virtuoso IC6.16 is provided.

2 VCO Overview

VCOs are the most important and complex component of the overall PLL/CDR design. The essential
idea behind a VCO design is to generate a clock signal based on the Barkhausen criteria for oscillation
which states that the magnitude of the VCO transfer function at the oscillation-frequency is 1 while
the phase is -180 degrees. Two most popular VCO topologies whose sample architectures can be
seen in Fig 4. Due to the superior noise performance we chose to design a LC-Tank base VCO. VCO
is the device that generate the target clock. Ideally, its output frequency should be linearly related
to the input control voltage. The Laplace transform function of the VCO is derived as follows:

ωout(t) = KV COvctrl(t) (1)

L[ωout(t)] = ωout(s) = KV COvctrl(s) (2)

φout(t) =

t∫
0

ωout(τ)dτ =

t∫
0

KV COvctrl(τ)dτ (3)

L[φout(t)] = φout(s) =
ωout(s)

s
=
KV COvctrl(s)

s
(4)

Thus, the Laplace transform function for the VCO is:

HV CO(s) =
φout(s)

vctrl(s)
=
KV CO

s
(5)

The KV CO is defined as the VCO gain.

3 Verilog-A Overview

Traditionally SPICE is used as a common simulation engine to simulate analog/mixed-signal circuit.
However, when simulating large networks the simulation times can become extremely long, thereby
limiting the allowed design revisions to the circuit designer. It is very tedious to describe the behavior
of a circuit using SPICE unless the complete physical transistor-level structure of the circuit is known
to the designer. Furthermore, the SPICE simulation process is very technology dependent in that
with technology scaling the SPICE models need to be updated as the older models become obsolete
and invalid for accurate simulation. The aforementioned design process has remained virtually the
same over the past few decades and even though the digital design synthesis process has progressed
significantly by incorporating electronic system-level (ESL) design automation techniques, the mixed
signal design process is very slow, laborious and therefore error-prone. Digital design engineers,
though work with millions of transistors have been able to automate the design flow, but analog
designers have been unable to do so even though most analog circuits only consist of tens of thousands
of devices.
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Verilog-A is a high-level Hardware Description Language (HDL) used to describe the structure and
behavior of analog and mixed-signal systems. It is an extension to the IEEE 1364 Verilog HDL stan-
dard and is very powerful in providing fast prototyping capabilities for mixed-signal systems. The
key advantage of circuit modeling using Verilog-A is that it provides a single language and simulator
ecosystem that can be shared between analog system-level as well as device-level designers. Verilog-
Aleverages the superior speed and capacity offered by traditional Verilog and allows event-driven
capabilities within analog model simulation, making it an attractive choice when simulating highly
complex mixed-signal circuits such as PLLs, CDRs, ADCs, and DACs. The only pitfall of using
Verilog-A is that it cannot replace traditional transistor level SPICE simulation completely as it
does not have synthesis capabilities like its digital counterpart Verilog. However, at the onset of the
design phase, using Verilog-AMS for circuit modeling is very powerful for a mixed-signal circuit/sys-
tem design engineer as it offers fast prototyping/verification for behavioral level simulation, thereby
expediting the time-to-market for the system. Verilog-A is a HDL language capable of performing
truly behavioral as well as transistor level co-simulation. Cadence has been the front-runner in pro-
moting the language making it an industry standard, and has led the majority of the advancement
efforts ever since its release in 2003. A typical skeleton of a Verilog-AMS code is shown in Figure 1
where the main components of a Verilog-A/AMS code are listed.

Figure 1: Verilog-AMS Sample Code

In the first line of the sample code shown in Figure 1, we include the ‘disciplines.vams’ header file.
This file is a collection of physical signal types that are commonly used in Verilog-AMS and are
thus referred to as ‘natures’. Electrical disciplines consist of ‘voltages’ and ‘currents’ and are used
most commonly during mixed-signal system modeling where ‘voltage’ and ‘current’ are ‘natures’.
Every Verilog-A component is defined as a ‘module’ and modules are the basic building blocks of
any given Verilog-A files as they describe the component being modeled. Ports are the points where
connections are made to the given component. Every port is required to have a direction associated
with it, and by default in Verilog-AMS language there are three types of ports: input, output
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and inout. The keyword electrical signifies that the signals associated with the ports described
as electrical are of ‘voltage’ and ‘current’ natures. Additionally, analog is the keyword after which
point the Verilog-AMS compiler starts actual modeling as the logic/process starts after the ‘analog
begin’. Finally, every Verilog-A component code should end with the word endmodule as it signifies
the point at which the compiler stops parsing of the code.

4 VCO Implementation Using Verilog-A

// Veri logA fo r TestLib , vco , v e r i l o g a
‘ include ” cons tant s . vams”
‘ include ” d i s c i p l i n e s . vams”
module vco ( vin , out ) ;
/∗ I /O Dec la ra t i ons ∗/
input vin ;
output out ;
e l e c t r i c a l v in ;
e l e c t r i c a l out ;
/∗ Parameter Dec la ra t i ons ∗/
parameter real Vmin=0; // Minimum input v o l t a g e
parameter real Vmax=Vmin+1 from (Vmin : i n f ) ; // Maximum input v o l t a g e
parameter real Fmin=1e9 from ( 0 : i n f ) ; // Minimum output f requency
parameter real Fmax=2e9 from (Fmin : i n f ) ; // Maximum output f requency
parameter real Vamp = 1.8 from [ 0 : i n f ) ; // Output s i nu so i d ampl i tude
parameter real t t o l =1u/Fmax from ( 0 : 1 /Fmax ) ; // Crossing time t o l e r anc e
parameter real v t o l = 1e−9; // Vol tage
// Minimum number po in t s per per iod f o r update
parameter integer min pts update=32 from [ 2 : i n f ) ;
// Trans i t ion time f o r square output
parameter real t ran t ime = 10e−12 from ( 0 : 0 . 3 /Fmax ) ;
// Std d e v i a t i on o f phase j i t t e r (UI)
parameter real j i t t e r s t d u i = 0 from [ 0 : 1 ) ;
/∗ I n t e rna l Var iab l e s ∗/
real f r e q ;
real phase ;
integer n ;
integer seed ;
real j i t t e r r a d ;
real dPhase ;
real p h a s e i d e a l ;
analog
begin

@( i n i t i a l s t e p )
begin

seed = 671 ;
n = 0 ;
dPhase = 0 ;
j i t t e r r a d = j i t t e r s t d u i ∗2∗ ‘M PI ;

end
// compute the f r e q from the input v o l t a g e
f r e q = ( (V( vin ) − Vmin)∗ (Fmax − Fmin) / (Vmax − Vmin) ) + Fmin ;
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$bound step (1/( min pts update ∗ f r e q ) ) ;
i f ( f r e q > Fmax) f r e q = Fmax ;
i f ( f r e q < Fmin) f r e q = Fmin ;
p h a s e i d e a l = 2∗ ‘M PI∗ idtmod ( f req , 0 . 0 , 1 . 0 , −0.5) ;
phase = p h a s e i d e a l + dPhase ;
@( c r o s s ( p h a s e i d e a l + ‘M PI /2 , +1, t t o l , v t o l )

or c r o s s ( p h a s e i d e a l − ‘M PI /2 , +1, t t o l , v t o l ) )
begin

dPhase = $rd i s t no rma l ( seed , 0 , j i t t e r r a d ) ;
end
@( c r o s s ( phase + ‘M PI /2 , +1, t t o l , v t o l )

or c r o s s ( phase − ‘M PI /2 , +1, t t o l , v t o l ) )
begin

n = ( phase >= −‘M PI/2)&&(phase < ‘M PI / 2 ) ;
end
// genera te the output
V( out ) <+ t r a n s i t i o n (n?Vamp: 0 , 0 , t ran t ime ) ;

end
endmodule

5 Cadence Simulation Steps for VCO

1. The VCO is the most critical component of a clocking circuit so we try to model using Verilog-A
because it allows us to behaviorally estimate the jitter specifications. Create a new library and
call it ‘TestLib’. Navigate to File → New → Cell − V iew and choose VerilogA in view-type
as shown Figure 2. Create a model for the VCO using code shown above and save the file as
‘vco’. Only the white-noise jitter is considered in this design and it is modeled by a Gaussian
white-noise probability distribution function.

Figure 2: VCO Verilog-A Testbench

2. If the code is error-free a pop up window will open asking whether you want to create a symbol
for the designed block. Select ‘Ok’ to create the symbol view for the VCO.

3. Figure 3 shows the ‘VCO’ testbench schematic. Create a new schematic named ‘vco tb’.

5



ECE 546 Mixed-Signal Circuit Simulation Guide Spring 2014

Figure 3: VCO Verilog-A Testbench

4. Click on the ‘VCO’ block and press q, a window as shown in Figure 4 will appear. Enter the
appropriate value of charge-pump current as per the design objectives.

Figure 4: VCO Verilog-A Testbench Variable Setup

5. The VCO circuit is supposed to generate a periodic square-wave output at the desired frequency
of interest (as a function of the control voltage) with a certain jitter level which in our case
is chosen to be 2% Unit-Interval (UI) of period. From the final output waveform shown in
Figure 5 it is clear that the ‘VCO’ is functioning correctly.

6



ECE 546 Mixed-Signal Circuit Simulation Guide Spring 2014

Figure 5: VCO Verilog-A Simulation Output

6. For a VCO, a key figure-of-merit is the control voltage tuning range. Thus, we have to perform a
parametric analysis in order to observe the change in ‘frequency’ as well as KV CO as a function
of ‘Vctrl’. In order to do so in the ADE setup window click on Tools→ Parametric Analysis
and a window like Figure 6 should pop-up. Within the parametric analysis window, when you
double-click on the variable box, a drop-down list will show up from which you should pick
‘vctrl’.

Figure 6: Vctrl Parametric Analysis Setup
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To run the parametric analysis, click on the ‘Play’ within the Parametric-Analysis window.
This setup is basically going to run the transient simulation To−From

StepSize times by varying the
control-voltage input to the VCO.

7. To plot frequency vs. Vctrl and KV CO vs. Vctrl we need to use the ‘Calculator’ tool in-built
within ADE. Click on Tools → Calculator. The Calculator window as shown in Figure 7
will open up and within it now you should select ‘Vt’ from the toolbar. The schematic will
open up, so within the schematic select the ‘vout’ node. From the ‘Function-Panel’ within
the Calculator window choose the ‘frequency’ and ‘average’ functions to make up the function
shown in Figure 7. Now go back to the ADE window, click on the right-pane and select the
‘Pick-Outputs’ button. A window will pop up so within it select ‘Get-Expression’ and name
it ‘freq’. This will bring the expression you just created in the Calculator so that you can plot
it. Conversely, you can also click on the ‘plot’ button shown in the red-box in Figure 7 to plot
the expressio; however, doing so makes the title of plot look a little too crammed.

Figure 7: ADE Calculator

8. Repeat the same steps as above to create an expression within the calculator to compute the
KV CO. Use the ‘deriv’ function within the Calculator Function Panel to do so. Finally, click
on the ‘Play’ button within the ADE window to plot frequency vs. Vctrl and KV CO vs. Vctrl
curves. Your output should look like Figure 8.
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Figure 8: Frequency vs. Vctrl and KV CO vs. Vctrl Simulation Plots

The KV CO calculated in Figure ?? is the value used to calculate the required charge-pump
current as well as C1 and C2 values from the loop-filter. Depending upon your chosen VCO
output frequency you can pick the corresponding KV CO value accordingly.

9. To simulate the jitter at the VCO output during lock-condition, select the vout waveform, click
on Measurements→ EyeDiagram. Your final output should look like that shown in Figure
9 once you click on ‘Plot Eye’. Note that this model is only behavioral so any transistor-
level non-idealities are not captured. Nevertheless, behavioral modeling is very powerful in
performing rapid prototyping of the clocking circuit core elements and performs a system level
noise/timing budget for the design.

Figure 9: VCO Verilog-A Jitter
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