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【仿真赛】手把手教您 Ansoft Maxwell工程仿真实例 

1. 静电场问题实例：平板电容器电容计算仿真 
平板电容器模型描述： 
上下两极板尺寸：25mm×25mm×2mm，材料：pec（理想导体） 

介质尺寸：25mm×25mm×1mm，材料：mica（云母介质） 

激励：电压源，上极板电压：5V，下极板电压：0V。 

要求计算该电容器的电容值 

 

1.建模（Model） 

Project > Insert Maxwell 3D Design 
File>Save as>Planar Cap（工程命名为“Planar Cap”） 
选择求解器类型：Maxwell > Solution Type> Electric> Electrostatic（静电的） 
创建下极板六面体 
Draw > Box（创建下极板六面体） 
下极板起点：（X,Y,Z）>（0, 0, 0） 
坐标偏置：（dX,dY,dZ）>（25, 25,0） 
坐标偏置：（dX,dY,dZ）>（0, 0, 2） 
将六面体重命名为DownPlate 
Assign Material > pec（设置材料为理想导体perfect conductor） 
创建上极板六面体 
Draw > Box（创建下极板六面体） 
上极板起点：（X,Y,Z）>（0, 0, 3） 
坐标偏置：（dX,dY,dZ）>（25, 25,0） 
坐标偏置：（dX,dY,dZ）>（0, 0, 2） 
将六面体重命名为UpPlate 
Assign Material > pec（设置材料为理想导体perfect conductor） 
创建中间的介质六面体 
Draw > Box（创建下极板六面体） 
介质板起点：（X,Y,Z）>（0, 0, 2） 
坐标偏置：（dX,dY,dZ）>（25, 25,0） 
坐标偏置：（dX,dY,dZ）>（0, 0, 1） 
将六面体重命名为medium 
Assign Material > mica（设置材料为云母mica，也可以根据实际情况设置新材料） 
创建计算区域（Region） 
Padding Percentage：0% 
忽略电场的边缘效应（fringing effect） 

 
电容器中电场分布的边缘效应 
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2.设置激励（Assign Excitation） 
选中上极板UpPlate, 
Maxwell 3D> Excitations > Assign（计划，分配） >Voltage > 5V 
选中下极板DownPlate, 
Maxwell 3D> Excitations > Assign >Voltage > 0V 
 

3.设置计算参数（Assign Executive Parameter） 
Maxwell 3D > Parameters > Assign > Matrix （矩阵）> Voltage1, Voltage2 
4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes > 10 
误差要求：        Percent Error > 1% 
每次迭代加密剖分单元比例： Refinement per Pass > 50% 
 
5. Check & Run 
 
6. 查看结果 

Maxwell 3D > Reselts > Solution data > Matrix 
电容值：31.543pF 
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2. 恒定电场问题实例：导体中的电流仿真 
恒定电场： 
导体中，以恒定速度运动的电荷产生的电场称为恒定电场，或恒定电流场

（DC conduction（传导）） 
恒定电场的源： 
（1）Voltage Excitation，导体不同面上的电压 
（2）Current Excitations，施加在导体表面的电流 
（3）Sink（汇），一种吸收电流的设置，确保每个导体流入的电流等于流出的
电流。只有在不使用Voltage Excitation时，才用Sink。保证 0J∇ ⋅ =  
DC conduction求解器： 
不计算导体外的电场，计算时，不考虑材料的介电常数参数。 

 
 
例：绘出如下图所示导体结构中的电流流向图 

 
 

1.建模（Model） 

Project > Insert Maxwell 3D Design 
File>Save as>Planar Cap（工程命名为“DC Conduction”） 
选择求解器类型：Maxwell > Solution Type> Electric> DC Conduction 
创建导体Conductor 
Draw > Box 
起点：（X,Y,Z）>（1, -0.6, 0） 
坐标偏置：（dX,dY,dZ）>（1, 0.2,0.2） 
将六面体重命名为Conductor 
Assign Material > Copper（设置材料为铜） 
创建另3个并列的导体 
Select Conductor 
Edit > Duplicate（重复）> Along Line（沿线复制） 
输入line矢量的第1个点：（0，0，0） 
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输入line矢量的第2个点：（0，0.4，0） 
输入复制总数：4（包括原导体） 
创建导体Conductor_4 
Draw > Box 
起点：（X,Y,Z）>（0.8, -1, 0） 
坐标偏置：（dX,dY,dZ）>（0.2, 2.2,0.2） 
将六面体重命名为Conductor_4 
Assign Material > Copper（设置材料为铜） 
创建导体Conductor_5 
Draw > Box 
起点：（X,Y,Z）>（0.8, -0.4, 0） 
坐标偏置：（dX,dY,dZ）>（-1.2, 0.2,0.2） 
将六面体重命名为Conductor_5 
Assign Material > Copper（设置材料为铜） 
创建导体Conductor_6 
Select Conductor_5 
Edit > Duplicate > Mirror（镜像复制） 
输入对称镜像平面法向量在平面中的第1点坐标：（0，0，0） 
输入对称镜像平面法向量在平面外的第2点坐标：（0，1，0） 
上述设置表示镜像平面为XOZ平面 
将六面体重命名为Conductor_6 
创建导体Conductor_7 
Draw > Box 
起点：（X,Y,Z）>（-0.4，0.6，0） 
坐标偏置：（dX,dY,dZ）>（-0.4, -1.2,0.2） 
将六面体重命名为Conductor_sink 
Assign Material > Copper（设置材料为铜） 
创建计算区域（Region） 
Padding Percentage：10% 
2.设置激励（Assign Excitation） 
按f，将体选择改为面选择 
2.1 设置电流注入源 
选中如下图所示6个面 
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Maxwell 3D> Excitations > Assign >Current > 1A 
Maxwell 在上述6个面上产生6个输入电流激励源 
2.2设置电流汇（Current Sink） 
选中Current_sink导体的下列2侧面 
Maxwell 3D> Excitations > Assign > Sink 

 

 

3.设置剖分操作（Assign Mesh Operations） 

选中所有物体，Ctrl+A 
Maxwell 3D> Mesh operations> Assign> Inside Selection> Length Based 
不选Restrict length of elements 
选中Restrict the number of elements 
输入maximum number of elements：10000（设置剖分单元的最大数量） 
 

http://www.ansys.com/
http://bbs.21dianyuan.com/


  http://www.ansys.com/  http://bbs.21dianyuan.com/  

 

 

4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
Default 
 
5. Check & Run 
 
6. 后处理 

绘出导体中的电流流向图 
选中所有导体 
Maxwell 3D > Fields > Fields >J > J_Vector 
调节矢量箭头尺寸 
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3. 恒定磁场问题实例：恒定磁场力矩计算  

计算如下图所示永磁体模块在线圈磁场中所受力矩。 

 
 

1.建模（Model） 

Project > Insert Maxwell 3D Design 
File>Save as>Magnetostatic（静磁）（工程命名为“Magnetostatic”） 
选择求解器类型：Maxwell >   Solution Type> Electric> Magnetostatic 
创建线圈 
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Draw > Regular Polygon（创建线圈横截面） 
中心点坐标：  （X,Y,Z）>（0, 5, 0） 
设置截面半径：（dX,dY,dZ）>（0.5, 0,0） 
截面多边形边数：Number of Segments: 12 
将多边形重命名为Coil（线圈） 
选中Coil 
Draw > Sweep > Around Axis（设置如下） 

 
Assign Material > copper（设置材料为铜） 
创建永磁体模型 
Draw > Box（创建下极板六面体） 
起点：（X,Y,Z）>（-3, -0.5, -0.5） 
坐标偏置：（dX,dY,dZ）>（6,1,1） 
将六面体重命名为Magnet（磁铁） 
Assign Material > NdFe35（设置材料为NdFe35铷铁硼材料） 

 
设置磁体的磁化方向（X,Y,Z）>（1,0,0）（磁体沿x轴正方向磁化） 
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创建激励电流加载面（Create Section） 
Select Coil 
Modeler > Surface > Section 
Modeler > Boolean > Separate Bodies（分离两Section面） 

删除1个截面 
Select 1个截面，Del 
将剩下的1个截面重命名为“Section1” 
 
旋转线圈和激励电流加载面 
选中 Coil和Section1 

 
 
创建计算区域（Region） 
Draw > Region 
Padding Percentage：100% 
 
2.设置激励（Assign Excitation） 
选中线圈截面：Section1 
Maxwell 3D> Excitations > Assign > Current  
Name: Current1 
Value: 100 
Type: Stranded（链） 

 

3.设置计算参数（Assign Executive Parameter） 
选中 Magnet 
Maxwell 3D > Parameters > Assign > Torque  
Name: Torque1 
Type: Virtual 
Axis: Global::Z, Positive 
 
4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes ： 15 
误差要求：        Percent Error:  1% 
每次迭代加密剖分单元比例： Refinement per Pass :  30% 
 
5. Check & Run 

 
6. 查看结果 
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Maxwell 3D > Reselts > Solution data > Torque 
力矩：-2.9288E-005 (N·m) 
 
XOY平面磁场强度幅值分布图 

 
XOY平面磁场强度方向矢量图 

 
 
 

4. 参数扫描问题实例：恒定磁场力矩计算  
计算如下图所示铁块所受线圈磁场的作用力。 
要求对线圈中的电流和铁块的高度做参数扫描，计算不同设置值时，

作用力的大小。 
 

 
 
1.建模（Model） 
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Project > Insert Maxwell 3D Design 
File>Save as> Parametric（工程命名为“Parametric”） 
选择求解器类型：Maxwell > Solution Type> Magnetostatic 
创建线圈  
Draw > Regular Polyhedron（创建多边形柱体1） 
Center Position（中心点坐标）：  （X,Y,Z）>（0, 0, 0）mm 
Start Position（起点坐标）：（X,Y,Z）>（1.25, 0,0）mm 
Axis（对称轴）：Z 
Height（柱体高度）：0.8mm 
多边形边数：Number of Segments: 36 
将多边形重命名为Polyhedron1 
 
选中Polyhedron1（创建多边形柱体2） 
CTRL_C，CTRL_V 
修改相关设置 
Center Position（中心点坐标）：  （X,Y,Z）>（0, 0, 0）mm 
Start Position（起点坐标）：（X,Y,Z）>（1, 0,0）mm 
Axis（对称轴）：Z 
Height（柱体高度）：0.8mm 
多边形边数：Number of Segments: 36 
将多边形重命名为Polyhedron2 
 
创建线圈 
选中Polyhedron1，Polyhedron2 
Modeler（建模） > Boolean > Subtract（减去） 
Blank Park: Polyhedron1 
Tool Park:  Polyhedron2 
将Polyhedron1重命名为Coil 
Assign Material > copper（设置材料为铜） 
 
创建铁块模型 
Draw > Box 
任意创建一个6面体 
尺寸参数设置如下： 
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注意：ZSize参数的值为：“SlugHeight” 

 

 
将六面体重命名为Slug 
Assign Material > iron（设置材料为iron） 
 
创建计算区域（Region） 
Draw > Region 
Padding Percentage：200% 
 
创建激励电流加载面（Create Section） 
Select Coil 
Modeler > Surface > Section 
Section Plane: YZ平面 
Modeler > Boolean > Separate Bodies（分离两Section面） 
删除1个截面 
Select 1个截面，Del 
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将剩下的1个截面重命名为“Section1” 
 
2.设置激励（Assign Excitation） 
选中线圈截面：Section1 
Maxwell 3D> Excitations > Assign > Current  

 
Value: AmpTurns 
Type: Stranded（线形激励电流） 

 
 
3.设置计算参数（Assign Executive Parameter） 
选中 Slug（弹头） 
Maxwell 3D > Parameters > Assign > Force  
Name: Force 1 
Type: Virtual 
 
4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
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最大迭代次数：    Maximum number of passes ： 5 
误差要求：        Percent Error:  1% 
每次迭代加密剖分单元比例： Refinement per Pass :  30% 
 
5. 创建参数扫描设置 
Maxwell 3D > Optimetrics Analysis > Add Parametric 
点击Add，创建扫描参数 
variable选择： SlugHeight  
linear step 
Start =1, Stop =2, Step = 0.5 
点击Add >>按键 
将SlugHeight的扫描设置添加到右边空白栏 
 
variable选择： AmpTurns （设置安匝数的扫描） 
linear step 
Start =100, Stop =200, Step =50 
点击Add >>按键 
将AmpTurns的扫描设置添加到右边空白栏 
点击OK. 

 
 
点击 Calculations子菜单 
点击 Setup Calculations 
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点击Add Calculations 

 

Setup1出现在Setup Sweep Analysis菜单中 
点击Done 
在Options 子菜单中 
选中如下设置 
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“Save Field and Mesh ” :在每一步参数扫描计算后，保存相应的计
算场量和剖分信息，一般，系统为节约内存，默认不保存。 
“Copy geometrically equivalent meshes” 在下次计算中，可重复使用
上次计算时未变形的模块的剖分数据。一般来说，频率扫描时，不推

荐使用该选项，因为Ansoft的剖分算法是与频率相关的。 
 
5. Check  
6.计算 
在Project Manager 窗口 
Optimetrics 
右键点击 ParametricSetup1 
选择 Analyze 
7. 查看结果 
右键点击 ParametricSetup1 
选择View Analysis Result 

 
在Project Manager 窗口 
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右键点击Create Report 

 

设置参数如下： 

 

点击New Report 
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5. 恒定磁场实例：三相变压器电感计算 
计算如下图所示变压器绕组的电感。（学习半对称模型的使用

half-symmetry） 

 
1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> Inductance （工程命名为“Inductance”） 
选择求解器类型：Maxwell > Solution Type> Magnetostatic 
改变作图单位Modeler > Units > Select Units: in (inches) 
 
创建变压器铁芯框架  
Draw > Box 
Position：  （-1,-6,0） 
Box尺寸：（XSize, YSize, ZSize）>（2,12,10） 
Draw > Box 
Position：  （-1,1 ,2） 
Box尺寸：（XSize, YSize, ZSize）>（2,3,6） 
选中Box2 
Edit > Duplicate > Around Axis 

Axis: Z 
Angle: 180 deg 
Total number: 2 
选中Box1 ，Box2，Box2_1 
Modeler > Boolean > Subtract 
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Blank Parts:  Box1 
Tool Parts:  Box2，Box2_1 

不要选：“Clone tool objectsbefore subtracting” 

Draw > Box（创建Gap（缺口）） 

 
选中Box1 ，Box3 
Modeler > Boolean > Subtract 
Blank Parts:  Box1 
Tool Parts:  Box3 

不要选：“Clone tool objectsbefore subtracting” 

选中Box1 

Modeler > Boolean > Separate Bodies 

将分离后的模型分别重命名为：“Core_E”（原Box1）和“Core_I” 

将两者的材料重设为：“steel_1008” steel（钢） 

创建线圈 

Modeler > Grid Plane > YZ 

Draw > Rectangle 

设置如下： 
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Modeler > Grid Plane > XY 

Draw > Rectangle 

设置如下： 

 
选中Rectangle2 

Modeler > Delete Last Operation（形成
Rectangle1围绕的轨迹） 
选中Rectangle1，Rectangle2 

Draw > Sweep > Along Path（可以形成环形线圈） 

Angle of twist: 0deg 

Draft Angle: 0deg 

Draft type: Round 

选中Rectangle1 

Edit > Duplicate > Along Line 

（X,Y,Z）>（ 0, 0, 0） 

（dX,dY,dZ）>（0, 0, 1.925） 
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Total Number: 3 

选中Rectangle1, Rectangle1_1, Rectangle1_2 

Edit > Duplicate > Along Line 

（X,Y,Z）>（ 0, 0, 0） 

（dX,dY,dZ）>（0, 5,0） 

Total Number: 3 

将Rectangle1, Rectangle1_1和 Rectangle1_2重命名为：Coil_left, 

Coil_left_1, Coil_left_2 

将中间柱上线圈重命名为：Coil_mid, Coil_ mid _1, Coil_ mid _2 

将右边柱上线圈重命名为：Coil_right, Coil_ right _1, Coil_ right _2 

将所有Coil的材料改为Copper 

创建激励电流加载面（Create Section） 

选中所有线圈 

Modeler > Surface > Section 

选中YZ平面 

Modeler > Boolean > Separate Bodies 

Edit > Delete（删除多余的面） 

将左边柱上的截面重命名为：Section1,  Section2 , Section3 

将中间柱上的截面命名为：Section4,  Section5 , Section6 

将右边柱上的截面命名为：Section7,  Section8 , Section9 

 
创建计算区域（Region） 
Draw > Region 
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2.设置激励（Assign Excitation） 
选中左边柱上线圈截面：Section1,  Section2 , Section3 
Maxwell 3D> Excitations > Assign > Current  
Name: PhaseA 
Value: -0.5*Mag 
Type: Stranded 
确认，弹出Add Variable窗口 
Variable：Mag > Value: 30A 
选中中间柱上线圈截面：Section4,  Section5 , Section6 
Maxwell 3D> Excitations > Assign > Current  
Name: PhaseB 
Value: Mag 
Type: Stranded 
选中右边柱上线圈截面：Section7, Section8 , Section9 
Maxwell 3D> Excitations > Assign > Current  
Name: PhaseC 
Value: -0.5*Mag 
Type: Stranded 
 
3.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes ： 10 
误差要求：        Percent Error:  1% 
每次迭代加密剖分单元比例： Refinement per Pass :  30% 
设置非线性残差：nonlinear residual: 0.001 
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4.设置计算参数（Assign Executive Parameter） 
设置参数Matrix1（此处设置可以实现串并联和线圈匝数的设置） 
Maxwell > Parameters > Assign > Matrix 
弹出Matrix 窗口 
在Setup子菜单下，include栏中确认打钩 
在Post Processing子菜单下，Turns栏中全部改为30 
选中PhaseA_1, PhaseA_2, PhaseA_3  
点击按键：Group -> 
将Group名改为PhaseA 
选中PhaseB_1, PhaseB_2, PhaseB_3  
点击按键：Group -> 
将Group名改为PhaseB 
选中PhaseC_1, PhaseC_2, PhaseC_3  
点击按键：Group -> 
将Group名改为PhaseC 
如下图所示： 

 
每个线圈有30匝，在同一个柱上的3个线圈是串联连接。 

设置参数Matrix2 
Maxwell > Parameters > Assign > Matrix 
弹出Matrix 窗口 
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在Setup子菜单下，include栏中确认打钩 
在Post Processing子菜单下，Turns栏中全部改为15 
选中PhaseA_1, PhaseA_2, PhaseA_3  
点击按键：Group -> 
将Group名改为PhaseA 
选中PhaseB_1, PhaseB_2, PhaseB_3  
点击按键：Group -> 
将Group名改为PhaseB 
选中PhaseC_1, PhaseC_2, PhaseC_3  
点击按键：Group -> 
将Group名改为PhaseC 
Branches全部改为3 
如下图所示： 

 
每个线圈有15匝，在同一个柱上的3个线圈是串联连接。 
 
5. Check & Run 
 
6. 查看结果 
Parameters > Matrix>(点击右键)选择：View Solution 
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继续仿真（根据模型的对称特点重新建模） 
 
1.创建对称模型 
右键点击Project Manager窗口中的MaxwellDesign1 
Copy 
右键点击Project Manager窗口中的inductance 
Paste 
拷贝了原工程 
Ctrl+A选中所有物体 
将原模型以YZ平面为对称面劈开，保留X轴正半轴的部分。 
Modeler > Boolean > Split（分割） 
Split Plane : YZ 
Keep Fragments: Positive side 
Split Objects: Split entire selection 
 
2.修改计算区域 
Draw > Region 
+X: 800 
-X: 0 
 
3.设置激励 
将模型旋转到Split面朝外 
按“f”键，切换选择方式为：面选择 
选中最右边的线圈截面 
Maxwell > Excitations > Assign > Current 
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Base Name: PhaseA_in 
Value: -0.5*Mag 
Type: Stranded 
选中最右边线圈的另一截面： 

 
Maxwell > Excitations > Assign > Current 
Base Name: PhaseA_out 
Value: -0.5*Mag 
Type: Stranded 
点击 Swap（交换）（ Direction ，保证电流的方向是流出截面。 
 
选中中间的线圈截面 

 
Maxwell > Excitations > Assign > Current 
Base Name: PhaseB_in 
Value: Mag 
Type: Stranded 
选中中间线圈的另一截面： 
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Maxwell > Excitations > Assign > Current 
Base Name: PhaseB_out 
Value: Mag 
Type: Stranded 
点击 Swap Direction，保证电流的方向是流出截面。 
 
选中最左边的线圈截面 

 
Maxwell > Excitations > Assign > Current 
Base Name: PhaseC_in 
Value: -0.5*Mag 
Type: Stranded 
选中最左边线圈的另一截面： 

 

Maxwell > Excitations > Assign > Current 
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Base Name: PhaseC_out 
Value: -0.5*Mag 
Type: Stranded 
点击 Swap Direction ，保证电流的方向是流出截面。 
激励设置完毕 
 
4.设置计算参数（Assign Executive Parameter） 
Maxwell > Parameters > Assign > Matrix 
弹出Matrix 窗口 
在Setup子菜单下，include栏中确认打钩 
在Post Processing子菜单下，Turns栏中全部改为30 
选中PhaseA_in_1, PhaseA_ in_2, PhaseA_ in_3  
点击按键：Group -> 
将Group名改为PhaseA 
选中PhaseB_ in_1, PhaseB_ in_2, PhaseB_ in_3  
点击按键：Group -> 
将Group名改为PhaseB 
选中PhaseC_ in_1, PhaseC_ in_2, PhaseC_ in_3  
点击按键：Group -> 
将Group名改为PhaseC 
5. Check & Run 
 
6. 查看结果 
Parameters > Matrix>(点击右键)选择：View Solution 

 

计算结果为原来的一半，因为模型也是原来的一半。 
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6. 永磁体磁化方向设置：局部坐标系的使用  
绘制4个同样形状的环状永磁体，对其设置不同的磁化方向，显示每
个永磁体磁环的磁场分布。 
 
1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> Magnet（工程命名为“Magnet”） 
选择求解器类型：Maxwell > Solution Type> Magnetostatic 

右键点击项目管理器中的MaxwellDesign1，重命名为Ring01 

 
创建第1个磁环  
Draw > Regular Polyhedron（创建多边形柱体1） 
输入center position： 
（X,Y,Z）: （0, 0, -4） 
输入圆柱体的半径和高度： 
（dX,dY, dZ）: （40, 0, 8） 
Number of segments ：36 
将RegularPolyhedron1重命名为Ring01_1，颜色改为blue 
 
Draw > Regular Polyhedron（创建多边形柱体2） 
输入center position： 
（X,Y,Z）: （0, 0, -4） 
输入圆柱体的半径和高度： 
（dX,dY, dZ）: （30, 0, 8） 
Number of segments ：36 
将RegularPolyhedron1重命名为Hole 
 
选中Ring01_1和Hole（用Ring01_1减去Hole，得到圆环柱） 
Modeler >Boolean > Subtract 
Blank Parts: Ring01_1 
Tool Parts: Hole 
 
2. 设置磁环Ring01_1的材料  
选中Ring01_1 
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Assign Material 
Add Material 
Material Name Mag01 
Material Coordinate System Cylindrical 
Magnitude（大小） -837000 
R Component 1 
Ring01_1磁环以全局坐标系Global的Z轴为对称轴，其磁化方向以Z轴
为轴心线，向外沿半径方向发散。 
 
创建第2个磁环  
选中Ring01_1  
右键：Edit > Duplicate >Along Line 
（X,Y,Z）：（0,0,0） 
（dX,dY,dZ）：（120,0,0） 
Total Number: 2  
将Ring01_1_1重命名为：Ring01_2  
 
创建局部坐标系：RelativeCS_Mag01_2 
Modeler > Coordinate（坐标）（ System > Create > Relative CS > Offset 
（X,Y,Z）：（120,-50,0）设置局部坐标系的坐标原点 
双击Coordinate Systems栏下的RelativeCS1，将其重命名为：
RelativeCS_Mag01_2 

 
选中Ring01_2 
鼠标右键点击，Edit > Properties 
将Ring01_2磁环的工作坐标系改为局部坐标系RelativeCS_Mag01_2： 
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Ring01_2磁环以局部坐标系RelativeCS_Mag01_2的Z轴为对称轴，磁
化方向向外沿半径方向发散。 
 
将工作坐标系切换回Global坐标： 
Modeler > Coordinate System > Set Working > Global 
 

创建磁环3和磁环4 
选中Ring01_1和Ring01_2  
右键：Edit > Duplicate >Along Line 
（X,Y,Z）：（0,0,0） 
（dX,dY,dZ）：（0,120,0） 
Total Number: 2  
将Ring01_1_1重命名为：Ring02_1 
将Ring01_2_1重命名为：Ring02_2 
 

创建Ring02_2磁环的局部坐标系：RelativeCS_Mag02_2 
Modeler > Coordinate System > Create > Relative CS > Both 
（X,Y,Z）：（120,120,0）设置局部坐标系的坐标原点 
设置坐标系的翻转： 
（dX,dY,dZ）：（1, 0,0），Enter  
（dX,dY,dZ）：（0, 0,-1）, Enter 
双击Coordinate Systems栏下的RelativeCS1，将其重命名为：
RelativeCS_Mag02_2 
 
将工作坐标系切换回Global坐标： 
Modeler > Coordinate System > Set Working > Global 
 
选中Ring02_2 
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鼠标右键点击，Edit > Properties 
将Ring02_2磁环的工作坐标系改为局部坐标系RelativeCS_Mag02_2： 
 
2. 设置磁环Ring02_1和Ring02_2的材料  
选中Ring02_1和Ring02_2 
鼠标右键：Assign Material 
Clone Material 
Material Name: Mag02 
Material Coordinate System: Cylindrical（圆柱） 
Magnitude: -837000 
R Component: 0 
Z Component: 1 
Ring02_1沿全局坐标系Global的Z轴方向磁化。 
Ring02_2沿局部坐标系RelativeCS_Mag02_2的Z轴方向磁环。 
 
3. 创建计算区域（Region） 
将工作坐标系切换回Global坐标： 
Modeler > Coordinate System > Set Working > Global 
Draw > Region 

 
 

4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes ： 10 
误差要求：        Percent Error:  3% 
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每次迭代加密剖分单元比例： Refinement per Pass :  30% 
非线性残差：Nonlinear Residual: 0.01 
 
5. Check & Run 
 
6. 查看结果 
绘出磁感应强度矢量图： 
Fields > B > B_Vector 
调整矢量箭头： 
Scale子菜单 
选中UseLimits 
Min： 0 
Max： 1 
Apply 
Marker/Arrow子菜单 
去除Map Size选项 
调节Size滑标到其1/3处 
Apply 
Plots子菜单 
选中 Uniform 
将Spacing size 滑标移到最小 
Min 3  
Maxs 10 
Apply. 
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7. Master/Slave边界使用实例：直流无刷电机内磁场计算  
计算如下图所示四极无刷直流电机内的磁场分布。通过对比全模型和

1/4模型的仿真，掌握匹配边界Master/Slave的用法。 

 
一．全模型仿真 
1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> Master_Slave 
将设计名由Maxwell3DDesign1改为Full_Model_1 
选择求解器类型：Maxwell > Solution Type> Magnetostatic 
创建电机模型 
调用模型库中的现有模型 
Draw > User Defined Primitive > Syslib > Rmxprt > SRMCore  
电机的参数设计如下： 

 
将模型名由SRMCore1改为Stator 
将材料改为镍（nickel） 
分离模型 
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全选所有模型Ctrl+A 
Modeler > Boolean > Separate Bodies 
将线圈重命名为按逆时针顺序改为Coil1，Coil2， Coil3， Coil4 

 

创建线圈的电流加载面 

选中4个线圈，得到线圈截面 

Modeler > Surface > Section > XY Plane 
分离线圈截面 
Modeler > Boolean > Separate Bodies 
删除多余的截面 
Del 
 
2.设置激励电流 
选中所有截面 
Maxwell > Excitations > Assign > Current  
Value ：100 Amps 
Type： Stranded 
 
创建计算区域（Region） 
Draw > Region 
Padding Percentage：10% 
 
3.设置自适应计算参数（Create Analysis Setup） 
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Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes ： 15 
误差要求：        Percent Error:  1% 
每次迭代加密剖分单元比例： Refinement per Pass :  30% 
 
4. Check & Run 
 
5. 查看结果 
Planes > Global: XY  
Field Overlays > Fields > H > H_Vector >Done 

 
 

二．1/4模型仿真 
在Project manager栏下，选中Full_Model_1 > Copy > Paste 
得到原设计的copy，重命名为Full_Model_2 
Ctrl+A，选中所有模型 
Modeler > Boolean > Split 
Split Plane > YZ 
Keep Fragments > Positive Side 
Split Objects > Split entire selection 
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Modeler > Boolean > Split 
Split Plane > XZ 
Keep Fragments > Positive Side 
Split Objects > Split entire selection 

 

修改Region区域 

 
 
旋转模型，使XZ面朝外 
按F键，将体选择改为面选择 
选中XZ面 
Assign Boundary > Master 
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选择New Vector 

 

沿着Z轴正方向设置U Vector向量 

起点（0，0，-20） 

终点（0，0，20） 

形成Master1面如下： 

 

旋转模型，使YZ面朝外 
选中YZ面 
Assign Boundary > Slave 
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得到下图 

 
Check & Run 
 
查看结果 
Planes > Global: XY  

Field Overlays > Fields > H > H_Vector >Done 
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8. 涡流场分析实例 

建立如下图所示的涡流分析模型 

 
1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> Eddycurrent（工程命名为“Eddycurrent”）  
选择求解器类型：Maxwell > Solution Type> eddy current 
改变作图单位Modeler > Units > Select Units: mm 
 
创建铝板模型（stock）  
Draw > Box 
Position：  （0,0,0） 
Box尺寸：（XSize, YSize, ZSize）>（294,294,19） 
重命名为：stock 
Draw > Box 
Position：  （18,18 ,0） 
Box尺寸：（XSize, YSize, ZSize）>（126,126,19） 
重命名为：hole 
CTRL +A，选中两Box模型 
Modeler > Boolean > Subtract 
Blank Parts:  stock 
Tool Parts:  hole 
得到铝板模型如下： 
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材料设置为Aluminum 
 
创建线圈模型（coil） 
Draw > Box 
Position：  （119,25,49） 
Box尺寸：（XSize, YSize, ZSize）>（150,150,100） 
重命名为：coilhole 
按 E 键，将体选择改为边选择 
选中coilhole模型的4个竖边，如下图所示： 

 

将所选边缘圆滑化 

Modeler > Fillet 
Fillet 参数设置： 
1. Fillet Radius: 25mm 
2. Setback Distance: 0mm 
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Draw > Box 
Position：  （94,0,49） 
Box尺寸：（XSize, YSize, ZSize）>（200,200,100） 
重命名为：coil 
按 E 键，将体选择改为边选择 
选中coil模型的4个竖边， 

将所选边缘圆滑化 

Modeler > Fillet 
Fillet 参数设置： 
1. Fillet Radius: 50mm 
2. Setback Distance: 0mm 
选中coil和coilhole模型 
Modeler > Boolean > Subtract 
Blank Parts:  coil 
Tool Parts:  coilhole 
得到coil模型如下： 
将coil的材料改为copper 

 
创建相对坐标系 

Modeler > Coordinate System > Create >Relative CS > Offset 
相对坐标偏置 X: 200, Y: 100, Z: 0 
 
设置激励电流加载面 
选中coil 
Modeler > Surface > Section > XZ 
Modeler > Boolean > Separate Bodies 
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Del 
 
2. 设置激励 
选中线圈的截面 

Maxwell 3D> Excitations > Assign > Current 

Name: Current1 

Value: 2742 A 

Type: Stranded 

 
设置涡流存在区域 

Maxwell 3D > Excitations > Set Eddy Effects 

 

 

创建计算区域（Region） 
Draw > Region 
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创建哑元Dummy 
Dummy技术的优点： 
只对所关心的局部区域进行加密剖分，提高该区域的计算精度，无需

对整个区域进行加密，节约了计算资源。 
将坐标系改为Global CS 
Draw > Box 
Position：  （-3,68,30） 
Box尺寸：（XSize, YSize, ZSize）>（300,8,8） 
重命名为：dummy 
材料为真空 

 

设置Dummy的剖分参数 
选中Dummy 
Maxwell > Mesh Operations > Assign > On Selection >Length Based. 
不选Restrict Length of Elements  
选中Restrict the Number of Elements  
Maximum Number of Elements：1000 
Select the menu item Maxwell>Analysis Setup > Apply Mesh Operations 
 
3.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：     Maximum number of passes ： 10 
误差要求：         Percent Error:  2% 
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每次迭代加密剖分单元比例： Refinement per Pass :  50% 
设置激励源的频率     Solver > Adaptive Frequency: 200 Hz 
 
4. Check & Run 
 
5.查看结果  
使用Calculator计算器 
绘出线段A（0，72，34），B（288，72，34）上的磁感应强度B的Z
向分量实部值 
设置Global CS为工作坐标系 
Draw > Line 
Select the menu item Draw > Line 
输入起点：X: 0.0, Y: 72.0, Z: 34.0 
Enter  
输入终点：X: 288.0, Y: 72.0, Z: 34.0 
Enter  
将线段重命名为：FieldLine 
 
计算B的z向分量实部 
Maxwell 3D> Fields > Calculator 
Quantity: B 
Vector: Scal? > Scalar Z 
General: Complex > Real 
Smooth  
Number  
Type: Scalar 
Value: 10000 
OK  
General: *  
点击Add 
输入Named Expression：Name: Bz_real 
Done 
Maxwell 3D > Results > Create Fields Report > Rectangular plot 
设置如下图： 
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点击New Report 

 
绘出stock中的涡流辐值分布： 

选中stock 

Maxwell 3D > Fields > Fields > J > Mag_J 
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绘出stock中的涡流流向图 

Maxwell 3D> Fields > Fields > J > Vector_J 
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9. 涡流场问题实例：磁偶极子天线的近区场计算  
计算如下图所示所受磁偶极子线圈的近区场在边界上的坡印廷矢量

及其辐射电阻。 
要求理解并掌握辐射边界的使用。 
注意：由于Maxwell软件只适用于低频场合，所以不推荐采用该平台
计算天线相关的高频场问题，本例只是为了说明如何使用辐射边界

（Radiation Boundary）。 

 

 
1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> Dipole antenna （工程命名为“Dipole antenna”） 
选择求解器类型：Maxwell > Solution Type> Eddy current 
设置几何尺寸单位： 
Modeler > Units > Select Units: m (meters)    
 
创建线圈  
Draw>Torus 
中心点：（0,0,0） 
输入线圈的内径：（0.0095,0,0） 
输入线圈的外径：（0.001,0,0）  
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将材料设置为Copper 
重命名为：coil 
创建计算区域Region 
Draw>Sphere 
中心点：（0,0,0） 
输入球形计算区域的半径：（0.06,0,0） 
材料设为vacuum 
 
创建激励电流加载面（Create Section） 
Select  coil 
Modeler > Surface > Section 
Section Plane: YZ平面 
Modeler > Boolean > Separate Bodies（分离两Section面） 
Del 删除1个截面 
将剩下的1个截面重命名为“current” 
 
2.设置激励（Assign Excitation） 
选中线圈截面：current 
Maxwell 3D> Excitations > Assign > Current  
Value: 1.414 
Type: soild 
 
设置涡流效应和位移电流存在区域 
Maxwell > Excitations > Set Eddy Effects  
设置如下图： 

 
 
设置辐射边界 Radiation Boundary 
关于辐射边界的一些基本知识： 
1．辐射边界在仿真电磁场开域问题时使用，辐射边界可完全吸收该
边界所包围区域内向外辐射的电磁波，不会造成电磁波的反射。 
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2．辐射边界只在涡流求解器中使用。 
3．辐射边界必须与位移电流（Displacement current）设置同时使用。 
4．辐射边界一般都设为球形（也可以是其他形状），辐射边界到辐
射源的距离一般大于电磁波波长的1/4。 
 
在天线的辐射问题中，一般习惯将研究目标或区域的尺寸表示为电磁

波波长（λ，lambda）的函数。 
 
将region的半径表示为λ的函数 
选中Region下的Create sphere 
将半径radius改为：lambda/4+0.01 (m) 
添加变量lambda的定义为：c0/frequ 
这里c0表示真空中的光速 
添加变量frequ的定义为：1.5GHz 
 
按 f 键，改为面选择 
选中Region的外表面 
Maxwell > Boundaries > Assign > Radiation…  
 
设置表面剖分的近似原则 
选中外表面 
Maxwell > Mesh Operations > Assign > Surface Approximation… 
Maximum surface deviation：ignore 
Set maximum normal deviation (angle)：15 deg 
Set aspect ratio：10 
 
Maximum surface deviation 
表面偏差距离：模型的剖分三角平面与真实表面之间的距离 
若模型真实表面是平面，则表面偏差距离为0。 
Maximum normal deviation 
模型的剖分三角平面与真实表面的法向分量之间的夹角。 
Aspect ratio 
剖分三角单元的Aspect ratio是指三角单元的外接圆半径与三角形内
径的比值。若该参数为1，表示三角单元为等边三角形。对于平面剖
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分，Aspect ratio的设置下限为4，对于曲面剖分，Aspect ratio的设置
下限为1.2。 
 
创建计算区域的外表面 
选中Region区域的外表面 
Modeler > Surface > Create Object From Face  
将该面重命名为Outside 
 
3.设置计算参数（Assign Executive Parameter） 
Maxwell 3D > Parameters > Assign > Matrix  
 
4.设置自适应计算参数（Create Analysis Setup） 
Maxwell 3D > Analysis Setup > Add Solution Setup 
最大迭代次数：    Maximum number of passes ： 5 
误差要求：        Percent Error:  10% 
频率设置： Solver > Adaptive Frequency:  1.5GHz 
 
5. Check & Run 
 
6.计算结果 
计算辐射电阻 
创建平均Poynting矢量的计算表达式 

{ }*1 Re
2

P E H= ×
r r r

 

Maxwell 3D > Fields > Calculator…  
Quantity > E 
Quantity > H 
Complex > Conj（取H矢量的共轭） 
Cross（叉乘操作） 
Complex > Real（取实部） 
Number > 0.5 
* 
点击Add… 
Named expressions > Poynting  
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Done 
 

辐射电阻的计算公式： 2
av

r
rms

PR
I

=  

其中 avP 是边界上的辐射功率，其表达式为： 

{ }*1 Re
2av

S S

P P dS E H dS= ⋅ = × ⋅∫∫ ∫∫
r rr r r

   

Maxwell > Fields > Calculator  

在Named Expressions栏中选中Poynting 

Copy to stack（将Poynting的计算设置copy到Calculator堆栈中）  

Geometry > Surface > Outside 

Normal（保留Poynting的法向分量） 

积分 

Eval（查看结果） 

 

查看阻抗矩阵 

Maxwell > Results > Solution Data  
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查看辐射边界上的Poynting矢量图 

选中Region的外表面 

Maxwell > Fields > Fields > Named Expression…  

选中Poynting 
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10. 瞬态场实例：TEAM WORKSHOP PROBLEM 24 
计算如下图所示电机转子中的磁场分布，线圈激励采用脉冲波形。 

 

1.建模（Model） 
Project > Insert Maxwell 3D Design 
File>Save as> rotational actuator（工程命名为“rotational actuator”） 
选择求解器类型：Maxwell > Solution Type> Transient 
设置几何尺寸单位： 
Modeler > Units > Select Units: mm 
 
创建定子外磁路 
Draw > Cylinder 
下极板起点：（X,Y,Z）>（0, 0, 0） 
坐标偏置：（dX,dY,dZ）>（104.5, 0,25.4） 
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重命名为Outer_arm 
颜色改为red 
选中Outer_arm 
CTRL+C 
CTRL+V 
得到第2个圆柱模型，将其重命名为Cylindertool 
将Cylindertool的半径改为83.1mm，其他参数不变 
选中Outer_arm和Cylindertool 
Modeler > Boolean > Subtract 
Blank Parts: Outer_arm 
Tool Parts: Cylindertool 
 
创建定子上的两磁极 
Draw > Box 
（X,Y,Z）>（-13.9, 0, 0） 
（dX,dY,dZ）>（27.8, -40, 25.4） 
选中该Box 
Edit > Arrange > Move 
输入位移矢量的起点（X,Y,Z）>（0, 0, 0） 
输入位移矢量的终点偏置（dX,dY,dZ）>（0, -45, 0） 
Edit>Duplicate>Mirror 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（0, 1,0） 
选中所有已绘制模型 
Modeler>Boolean>Unite 
 
Draw > Cylinder 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（53.75, 0, 25.4） 
选中Outer_arm和Cylinder1 
Modeler>Boolean>Subtract 
Blank Parts: Outer_arm 
Tool Parts: Cylinder1 
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创建转子 
Draw > Cylinder 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（25.4, 0, 25.4） 
重命名为Shaft 
Draw > Cylinder 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（38.1, 0, 25.4） 
重命名为Inner_arm 
选中Shaft和Inner_arm 
Modeler>Boolean>Subtract 
Blank Parts: Inner_arm 
Tool Parts: Shaft 
创建转子上的两磁极 
Draw > Box 
（X,Y,Z）>（-12.7, 0, 0） 
（dX,dY,dZ）>（25.4, -20, 25.4） 
选中该Box 
Edit>Arrange>Move 
输入位移矢量的起点（X,Y,Z）>（0, 0, 0） 
输入位移矢量的终点偏置（dX,dY,dZ）>（0, -35, 0） 
Edit>Duplicate>Mirror 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（0, 1,0） 
选中Inner_arm和刚绘制的2个Box模型 
Modeler>Boolean>Unite 
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将新模型重命名为Innerarm 
Draw > Cylinder 
（X,Y,Z）>（0, 0, 0） 
（dX,dY,dZ）>（51.05, 0, 25.4） 
选中Innerarm和新创建的Cylinder2 
Modeler > Boolean > Intersect 

 

 

创建转子上的两线圈 

先创建局部相对坐标系 
Modeler > Coordinate System > Create > Relative CS > Offset 
输入坐标偏置（X,Y,Z）>（0, 0, 12.7） 
将局部坐标系设为工作坐标系 
将绘图平面设为XZ平面：Modeler > Grid plane > XZ 
Draw > Rectangle 
（X,Y,Z）>（-17, 0, -15.5） 

（dX,dY,dZ）>（34, 0, 31） 

Edit > Select > Faces 
选中刚创建的Rectangle 

Modeler>Surface>Uncover Faces 

由矩形平面得到闭合的矩形边框线，重命名为path 

将绘图平面设为YZ平面：Modeler > Grid plane > YZ 

绘制导线的截面： 
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Draw > Rectangle 
（X,Y,Z）>（0, 0, 15.5） 
（dX,dY,dZ）>（0, 17, 24） 
将新创建的Rectangle重命名为coil1 

选中path和coil1 

Draw > Sweep>Along Path 

OK 

将线圈的边圆滑化 

将局部坐标系设为工作坐标系 

将绘图平面设为XZ平面：Modeler > Grid plane > XZ 

Draw > Cylinder 
（X,Y,Z）>（0, 0, 0） 

（dX,dY,dZ）>（43, 17, 0） 

选中新创建的Cylinder和coil1 

Modeler > Boolean > intersection 
重命名为coil 
选中coil 
Edit>Arrange>Move 
输入位移矢量的起点（X,Y,Z）>（0, 0, 0） 
输入位移矢量的终点偏置（dX,dY,dZ）>（0, 54.5, 0） 
Edit>Duplicate>Mirror 
（X,Y,Z）>（0, 0, 0） 

（dX,dY,dZ）>（0, 1,0） 

 

创建激励电流加载面 

选中两线圈 
Modeler > Surface>Section > XY 
Modeler > Boolean>Separate Bodies 
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Del 
 
创建Region区域 
设为250% 
 
选中Innerarm 
Edit>Arrange>Rotate 
Axis：Z 
Angle: 29.5 deg 

 

 

2.设置材料 

设置定子为非线性材料 
选中Out_arm 
Assign Material > Add Material 
Material Name: arm steel 
在Relative Permeability参数的Type栏下，将simple改为Nonlinear 
点击BH Curve，弹出BH Curve窗口 
在H和B列分别输入下列数据 
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点击OK 
点击Validate，点击OK 
将电导率Bulk Conductivity设为1000000S/m 
 
设置Out_arm的材料为arm steel 
将Innerarm的材料也设为arm steel 
将两线圈的材料设为Copper 

3.设置激励 

在Sheets栏下选中1个电流加载面 
Assign Excitation > Coil Terminal >350 
在Number of Conductors栏输入350 
在Sheets栏下选中另1个电流加载面 
Assign Excitation > Coil Terminal 
在Number of Conductors栏输入350 
 
在模型窗口右键单击 
Assign Excitation > Add Winding  
弹出Winding Definition窗口 
在Type栏选择External，并选中Stranded，其他设置不变 
在Project Manager栏选中Winding1，右键单击，选择Add Terminals 
在弹出窗口中，选中之前定义的两个线圈截面 
此时，两线圈截面已属于Winding 
 
设置外部激励电路 
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打开外部电路编辑器： 
开始>所有程序>Ansoft>Maxwell 12>Maxwell Circuit Editor 
点击Project Manager 下的Components子栏 
放置线圈 
Maxwell Circuit Elements > Dedicated Elements > Winding 
将Winding元件拖到绘图区域 
右键 > Finish 
将线圈重命名为Winding1，与Maxwell中的线圈同名 
放置电阻 
Maxwell Circuit Elements > Passive Elements > Res 
将Res元件拖到绘图区域 
右键 > Finish 
将电阻值改为3.09欧 
放置电压脉冲信号源 
Maxwell Circuit Elements > Sources > VPulse 
将Res元件拖到绘图区域 
右键 > Finish 
按下列参数设置电压脉冲源 
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连接各元件：Draw > Wire 
放置参考地：Draw > Ground 
连接Ground 
 
导出电路的网络连接表 
Maxwell Circuit > Browse Netlist  
Netlist > Export 
将文件命名为：“trans_circ”，保存 
将工程保存为“rot_ext_circuit” 
退出Maxwell Circuit Editor 
 
在Maxwell 3D下设置外部激励 
Maxwell 3D>Excitations>External Circuit>Edit External Circuit. 
点击Import Circuit 
导入“trans_circ.sph”文件 
 
 
4.设置剖分规则 
选中Outer_arm和Innerarm 
Assign Mesh Operation>Inside Selection>Length Based. 
Maximum Length of Elements: 10mm 
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5.设置涡流效应 
Maxwell 3D>Excitations>Set Eddy Effects. 

 
 
6.设置求解规则 
Analysis>Add Solution Setup 
General：  Stop time>0.06s 
           Time step>0.005s 
Save Field: Type>Linear step 
    Start >0.001 

Stop >0.056  
Step> 0.005  

Add to list 
OK 
 
7. CHECK & RUN 
 
8.后处理 
绘制模型中间对称面上磁体中的磁场强度矢量图 
选中Innerarm和Outer_arm模型 
Modeler>List>Create>Object List 
 
View>Set Solutions Context 
设置后处理结果的时间间隔 
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Time > 0.01 
OK 
 
将工作坐标设为局部相对坐标系 
在Planes下选中RelativeCS1:XY 
Field Overlays>Fields>B>B_Vector 
Quanticy> B_Vector 
In Volume> Objectlist1 

 
 

 

 

 

绘制模型中间对称面上磁体中的电流强度幅值图 
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图中明显可以看出电流的趋肤效应 

 

绘出激励电流随时间变化的曲线 

Results>Create Transient Report>Rectangular Plot 

New Report 

 
 
 
 
 
 
 
绘出转子力矩随时间变化的曲线 
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Ansoft 快捷键 
o: 选中实体 
f：选中实体的某一面 
e：选中实体的某一边 
v：选中实体的某一顶点 
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